Perks and Benefits Unresponsive
Incident Report for GIIFTXoxoday Application Status
Resolved
There was a technical issue on the hosting provider that brought down the application. Its resolved now and the site is working.
Posted May 08, 2024 - 06:34 UTC
Update
We are continuing to investigate this issue.
Posted May 08, 2024 - 06:05 UTC
Investigating
We are currently investigating this and try to resolve this fast.
Posted May 08, 2024 - 06:03 UTC
This incident affected: GIIFTXoxoday (Plum) (Perks and Benefits).