Stores unavailable for end customers to place order
Incident Report for GIIFTXoxoday Application Status
Postmortem

During the patching activity, there was an issue with deployment. The issue has been resolved and steps to prevent this issue in the future have been taken.

Posted Apr 19, 2024 - 05:08 UTC

Resolved
GIIFTXoxo store was down
Posted Apr 18, 2024 - 13:00 UTC