Empuls Reports exhibiting suboptimal performance
Incident Report for GIIFTXoxoday Application Status
Resolved
The empuls reports performance issue has been successfully resolved.
Posted May 01, 2024 - 11:24 UTC
Investigating
We are actively investigating the root cause to restore optimal functionality swiftly. Appreciate your patience as we work to address this issue.
Posted May 01, 2024 - 09:53 UTC
This incident affected: GIIFTEmpuls (Empuls Web App).