Redemption Orders are Failing
Incident Report for GIIFTXoxoday Application Status
Postmortem

We had a low balance with one of our redemption partners. We restored the balance as soon as we became aware of it. In order to prevent this from happening again, we have taken steps internally.

Posted May 10, 2024 - 10:11 UTC

Resolved
This incident has been resolved.
Posted May 10, 2024 - 08:08 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 10, 2024 - 08:00 UTC
This incident affected: GIIFTEmpuls (Empuls Stores).