PlumPro order apis were doen

Incident Report for GIIFTXoxoday Application Status

Resolved

Root Cause:
Two users were present in the system:
product_listing@%
product_listing@10.0.%.%

An access denied error occurred for user@10.0.%.% from product_listing pods. The wildcard (%) in user@% allows access from any host, but both user password were different Likely, user@% does not have sufficient privileges to perform the operation in the absence of user@10.0.%.%.

The system was relying on the presence of user@10.0.%.% permission or plum pro api functionality.

Removing user@10.0.%.% caused dependency failure in plumpro apis.

Solution
Dropped both users and created user with wildcard solved the issue
Posted Oct 30, 2025 - 12:35 UTC

Investigating

We are currently investigating this issue.
Posted Oct 30, 2025 - 12:00 UTC
This incident affected: Plum (Plum Stores).